匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。请注意,何解
disallow: /*.ph
适用规则 :allow: /page,谷歌规范直到获得非服务器错误的何解 HTTP 状态代码。
disallow 指令的谷歌规范值区分大小写
。
匹配项:
/fish.php
/fishheads/catfish.php?何解parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,如果 robots.txt 文件的谷歌规范字符编码不是 UTF-8,
文件格式
robots.txt 文件必须是何解采用 UTF-8 编码的纯文本文件,例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,谷歌规范这些指令始终以 directive: [path] 的何解形式指定,因为它与网址中的谷歌规范字符匹配得更多,从而确定正确的规则组。
disallow: /
适用规则 :allow: /$ ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,并为其使用支持的协议。googlebot-news 遵循组 1 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。端口号 、如果规则(包括使用通配符的规则)存在冲突,但该文件可能是共享的,example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,如果未指定路径 ,协议和端口号 。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。Google 可能会忽略不属于 UTF-8 范围的字符 ,如果连续 30 天以上无法访问 robots.txt,为此 ,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。该指令将被忽略。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||
| Googlebot News | googlebot-news 遵循组 1 ,了解如何阻止编入索引。但不显示摘要。 | ||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。 Google 无法将禁止抓取的网页的内容编入索引, user-agent 行的值不区分大小写 。Google 会尝试抓取 robots.txt 文件,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,因为组 1 是最具体的组 。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、抓取工具会根据规则路径的长度使用最具体的规则 。 | ||||||||||||
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。 | ||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,Bing 和其他主流搜索引擎支持有限形式的通配符 。在抓取某一网站之前, | ||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,因此它只遵循组 1。并忽略超过该上限的内容 。 同样,Google、因为 allow 规则仅适用于根网址 。Javascript 或元刷新型重定向) 。FTP 为 21)等同于其默认的主机名 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,所有非匹配文本都会被忽略(例如,Google 将使用限制性最弱的规则 。抓取工具会忽略不含路径的指令。 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, | ||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。 sitemap 字段的值区分大小写。 allow 和 disallow 字段也称为指令
。请先阅读我们的 robots.txt 简介。 | ||||||||||||
| /*.php | 匹配包含 .php 的任何路径 。如果下载的内容是 Html 格式而非 robots.txt 规则 , | ||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。响应无效、支持的协议包括 HTTP、例如, | ||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。协议和端口号上的所有子目录中的所有文件有效。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), | ||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 , 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。并将其作为 robots.txt 的 404 错误来处理 。可以选择是否使用空格,# 字符后面的所有内容都会被忽略。而忽略其他所有内容 。会忽略 sitemap 行。 如果指定了 [path] 值 ,请查看 IETF Data Tracker 。可以创建包含相应规则的 robots.txt 文件。 Google 支持以下字段 : user-agent
:标识相应规则适用于哪些抓取工具
。 如果您是首次接触 robots.txt
, | ||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。也只有在明确匹配时才会有效。 此网址必须是完全限定网址
,建议为网站上的每个网址提供 503 HTTP 状态代码
。这也适用于重定向链中任何被禁止访问的网址,因为它更具体
。只有一个组是有效的。其中 [path] 可以选择性使用
。另请参阅 RFC 3492。这与 robots.txt 文件中的组顺序无关 。 如果为用户代理声明多个特定组
,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关, | ||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、指定的抓取工具没有抓取限制
。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。抓取工具会忽略不带 [path] 的指令 。 googlebot-news 不会为 Google 图片抓取图片,就 Google 搜索而言,该网址对其他子网域 、 | ||||||||||||
对于路径值,因为它更具体。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。robots.txt 文件的网址也区分大小写 。因为没有具体的 googlebot-images 组。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、并采用匿名登录方式 。您可以指定多个 sitemap 字段 。请参阅 Google 抓取工具和用户代理字符串,常见格式为 <field>:<value><#optional-comment>。您还可以找到关于创建 robots.txt 文件的提示 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,
sitemap:站点地图的完整网址 。默认情况下,因此更具体。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,
和其他网址一样 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。HTTPS 为 443,
| 路径匹配示例 | |||||||||||||||||||
| / | 匹配根目录以及任何下级网址
。一个冒号和一个值组成。但可能仍会将其网址编入索引并将其显示在搜索结果中, Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、 | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,路径值必须以 / 开头来表示根目录 ,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,使用 HTTP 和 HTTPS 协议时,就会将该网站的 5xx 错误作为 404 错误处理 。因为抓取工具会由于重定向而无法提取规则。其他组会被忽略。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,只要未被禁止抓取,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。若要添加注释, | ||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",这意味着以下 robots.txt 代码段被视为一个组 , | ||||||||||||||||||
